Identification



Welcome, Guest
Please Login or Register.    Lost Password?

Accents in module lang file
(1 viewing) (1) Guest
Go to bottomPage: 1
TOPIC: Accents in module lang file
#21878
Accents in module lang file 1 Year, 3 Months ago Karma: 0
Hi all guys,
I have created a new module for Dolibarr 3.2.x., the structure is:
modulename/...
modulename/langs/en_US/modulename.lang
modulename/langs/fr_FR/modulename.lang
modulename/...

In the french language file, I have strings with accents.

If Dolibarr language is set to English everything is OK, but if I set language in French, every string containing accents is not displayed here:
www.dolibarr.local/admin/modules.php?mainmenu=home

In the language file I have:
Code:

CHARSET= UTF-8
Module123456Name=Nom du Mudule
Module123456Desc=Description avec èéà accents



The string Module123456Name is correctly translated, but the string Module123456Desc is not displayed at all.

How can I fix that ?

Thank you for your help.
kess
Fresh Boarder
Posts: 2
graphgraph
User Offline Click here to see the profile of this user
Last Edit: 2012/12/31 13:05 By kess.
The administrator has disabled public write access.
 
#21879
Assume lousy tablets-us 1 Year, 3 Months ago Karma: 0
generic cialis
-+- generic cialis
buycialisonlinetoday.com/#50847 - generic cialis
Darcolem
Fresh Boarder
Posts: 1
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#21882
Re: Accents in module lang file 1 Year, 3 Months ago Karma: 10
Hi,

I'm not a developer but it reminds me that I already faced such issue while playing with French language files: are you sure that you saved the .lang file as UTF-8 format (should be a setting of your editor) ?

Rgds and HAPPY NEW YEAR TO EVERYONE
humphrey
Gold Boarder
Posts: 164
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#21885
Re: Accents in module lang file 1 Year, 3 Months ago Karma: 0
humphrey wrote:
Hi,

I'm not a developer but it reminds me that I already faced such issue while playing with French language files: are you sure that you saved the .lang file as UTF-8 format (should be a setting of your editor) ?

Rgds and HAPPY NEW YEAR TO EVERYONE

Thank you very much for your reply, after file format modification it worked like a charm.
Bye Kess
kess
Fresh Boarder
Posts: 2
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
Go to topPage: 1