# Installing my Dolibarr

**URL:** https://www.dolibarr.org/forum/c/installing-my-dolibarr/6.md?page=1

[Latest](https://www.dolibarr.org/forum/latest.md) · [Categories](https://www.dolibarr.org/forum/categories.md) · [Tags](https://www.dolibarr.org/forum/tags.md)

**Page:** 2

---

## [STARTTLS connection failed](https://www.dolibarr.org/forum/t/starttls-connection-failed/18771)

<div class="topic-metadata">

**Author:** [@adnanbutt050](https://www.dolibarr.org/forum/u/adnanbutt050)\
**Replies:** 19\
**Last updated:** [July 17, 2025, 9:38pm UTC](https://www.dolibarr.org/forum/t/starttls-connection-failed/18771 "2025-07-17T21:38:45Z")

</div>

Hello Everyone, After updating dolibarr from version 10 to version 11, I am unable to send emails from the dolibarr. I am getting this error while sending emails. Error \[132\]: STARTTLS connection failed. Error \[121\]: …

---

## [Dolibarr LTS version](https://www.dolibarr.org/forum/t/dolibarr-lts-version/29464)

<div class="topic-metadata">

**Author:** [@hansem](https://www.dolibarr.org/forum/u/hansem)\
**Replies:** 2\
**Last updated:** [June 3, 2025, 6:11pm UTC](https://www.dolibarr.org/forum/t/dolibarr-lts-version/29464 "2025-06-03T18:11:10Z")

</div>

Hi, I’ve just found this github project which doesn’t seem to be really active. Is the creation of an LTS version still on the agenda?

---

## [Ubuntu Dolibarr Install Stuck at /step2.php](https://www.dolibarr.org/forum/t/ubuntu-dolibarr-install-stuck-at-step2-php/30318)

<div class="topic-metadata">

**Author:** [@RSAutomation](https://www.dolibarr.org/forum/u/RSAutomation)\
**Replies:** 4\
**Last updated:** [May 13, 2025, 1:30pm UTC](https://www.dolibarr.org/forum/t/ubuntu-dolibarr-install-stuck-at-step2-php/30318 "2025-05-13T13:30:21Z")

</div>

Attempting a fresh Dolibarr 12.0.5 install on Ubuntu 24.04. Can’t proceed past /install/step2.php - no “next” button appears. Any direction would be appreciated. Screenshot: https://freeimage.host/i/3eKySwB

---

## [Fresh install V21.0.1 with Security token expired & conf.php issue](https://www.dolibarr.org/forum/t/fresh-install-v21-0-1-with-security-token-expired-conf-php-issue/30285)

<div class="topic-metadata">

**Author:** [@wesleyckng](https://www.dolibarr.org/forum/u/wesleyckng)\
**Replies:** 4\
**Last updated:** [May 11, 2025, 9:23am UTC](https://www.dolibarr.org/forum/t/fresh-install-v21-0-1-with-security-token-expired-conf-php-issue/30285 "2025-05-11T09:23:45Z")

</div>

I installed a fresh ver 21.0.1 on Inmotion web server. Both Mysql Version & Php are ok and I had created an empty conf.php file. however, both Security token expired & conf.php error message keep pop up. is there any…

---

## [SQL Error DB\_ERROR\_SYNTAX You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'integer DEFAULT NULL )ENGINE=innodb' at line 88](https://www.dolibarr.org/forum/t/sql-error-db-error-syntax-you-have-an-error-in-your-sql-syntax-check-the-manual-that-corresponds-to-your-mariadb-server-version-for-the-right-syntax-to-use-near-integer-default-null-engine-innodb-at-line-88/22794)

<div class="topic-metadata">

**Author:** [@tarunmeena](https://www.dolibarr.org/forum/u/tarunmeena)\
**Replies:** 2\
**Last updated:** [May 9, 2025, 9:17am UTC](https://www.dolibarr.org/forum/t/sql-error-db-error-syntax-you-have-an-error-in-your-sql-syntax-check-the-manual-that-corresponds-to-your-mariadb-server-version-for-the-right-syntax-to-use-near-integer-default-null-engine-innodb-at-line-88/22794 "2025-05-09T09:17:33Z")

</div>

Hello, On Step2 i am getting below error # SQL Error DB\_ERROR\_SYNTAX You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ‘integer DEFA…

---

## [Database passwords with DoliDeb Installation are?](https://www.dolibarr.org/forum/t/database-passwords-with-dolideb-installation-are/14325)

<div class="topic-metadata">

**Author:** [@holger3208](https://www.dolibarr.org/forum/u/holger3208)\
**Replies:** 13\
**Last updated:** [April 26, 2025, 2:13pm UTC](https://www.dolibarr.org/forum/t/database-passwords-with-dolideb-installation-are/14325 "2025-04-26T14:13:45Z")

</div>

Hello, I tried to install the last DoliDeb Version with Dolibarr 3.5.8 on my new ubuntu System. As you can see at the screenshots below everything goes fine, till the question of Superuser and Password. The Login name…

---

## [Has anyone successfully set up Dolibarr inside DDEV?](https://www.dolibarr.org/forum/t/has-anyone-successfully-set-up-dolibarr-inside-ddev/23839)

<div class="topic-metadata">

**Author:** [@montag](https://www.dolibarr.org/forum/u/montag)\
**Replies:** 2\
**Last updated:** [April 23, 2025, 10:33am UTC](https://www.dolibarr.org/forum/t/has-anyone-successfully-set-up-dolibarr-inside-ddev/23839 "2025-04-23T10:33:09Z")

</div>

We are trying to install Dolibarr on both macOS and Ubuntu 22.04 LTS within DDEV and can’t get the Dolibarr conf.php file to generate because it’s not seeing the database (called db) or root user (username db with pass d…

---

## [Show proposal colum with VAT](https://www.dolibarr.org/forum/t/show-proposal-colum-with-vat/30219)

<div class="topic-metadata">

**Author:** [@loderx](https://www.dolibarr.org/forum/u/loderx)\
**Replies:** 2\
**Last updated:** [April 14, 2025, 11:46pm UTC](https://www.dolibarr.org/forum/t/show-proposal-colum-with-vat/30219 "2025-04-14T23:46:21Z")

</div>

Hi, i need to show proposal colum price for each products with VAT in PDF file for clients. Any idea how to?

---

## [Default character set and collation](https://www.dolibarr.org/forum/t/default-character-set-and-collation/20196)

<div class="topic-metadata">

**Author:** [@PILAFTSIS](https://www.dolibarr.org/forum/u/PILAFTSIS)\
**Replies:** 9\
**Last updated:** [April 14, 2025, 1:03pm UTC](https://www.dolibarr.org/forum/t/default-character-set-and-collation/20196 "2025-04-14T13:03:45Z")

</div>

Dear all, I have some trables with installation related to char set. So I would like to ensure: Utf8 is the character set. Can we use utf32? collation is utf8\_general\_ci. Am i correct can we use \_universal\_ci on what…

---

## [A bash scripting tool for managing Dolibarr docker containers](https://www.dolibarr.org/forum/t/a-bash-scripting-tool-for-managing-dolibarr-docker-containers/30057)

<div class="topic-metadata">

**Author:** [@sysfredintech](https://www.dolibarr.org/forum/u/sysfredintech)\
**Replies:** 2\
**Last updated:** [April 12, 2025, 7:33pm UTC](https://www.dolibarr.org/forum/t/a-bash-scripting-tool-for-managing-dolibarr-docker-containers/30057 "2025-04-12T19:33:00Z")

</div>

Hello everyone I’d like to share with you a tool that i have scripted and which is very useful to me, perhaps you’d like to try it out. It needs to be improved so your feedback will be most welcome. This bash script le…

---

## [Where can I get the user and password after installation?](https://www.dolibarr.org/forum/t/where-can-i-get-the-user-and-password-after-installation/30202)

<div class="topic-metadata">

**Author:** [@allon\_xu](https://www.dolibarr.org/forum/u/allon_xu)\
**Replies:** 2\
**Last updated:** [April 6, 2025, 7:02am UTC](https://www.dolibarr.org/forum/t/where-can-i-get-the-user-and-password-after-installation/30202 "2025-04-06T07:02:32Z")

</div>

I was installing Dolibarr 21.0.0, and there was no prompt to set up the login username and password. After the installation, how do I log in? I’ve been searching the forum for a long time, but I couldn’t find anything, n…

---

## [Issue with Fresh Installation "Step2" of Dolibarr 11.0.0 on Debian 12 (Proxmox LXC)](https://www.dolibarr.org/forum/t/issue-with-fresh-installation-step2-of-dolibarr-11-0-0-on-debian-12-proxmox-lxc/30203)

<div class="topic-metadata">

**Author:** [@Lowees](https://www.dolibarr.org/forum/u/Lowees)\
**Replies:** 1\
**Last updated:** [April 5, 2025, 8:54am UTC](https://www.dolibarr.org/forum/t/issue-with-fresh-installation-step2-of-dolibarr-11-0-0-on-debian-12-proxmox-lxc/30203 "2025-04-05T08:54:57Z")

</div>

Hello Everyone, I’m currently trying to replicate an existing Dolibarr setup that was running on a Windows 10 HP laptop (using XAMPP 7.4.2). I have copied all the Dolibarr files and moved them to a Proxmox 8.3 LXC conta…

---

## [Messed up Installation of Dolibarr 21 using DoliDeb](https://www.dolibarr.org/forum/t/messed-up-installation-of-dolibarr-21-using-dolideb/30198)

<div class="topic-metadata">

**Author:** [@IAmTheRealBeef](https://www.dolibarr.org/forum/u/IAmTheRealBeef)\
**Replies:** 1\
**Last updated:** [April 3, 2025, 2:06pm UTC](https://www.dolibarr.org/forum/t/messed-up-installation-of-dolibarr-21-using-dolideb/30198 "2025-04-03T14:06:30Z")

</div>

I had Dolibarr 20.0.3 installed, and wanted to upgrade to 21.0.0. I used the Dolideb installation method. However after downloading and running the 21.0.0 deb, it appears my database has been wiped clean. It also displa…

---

## [Dolibarr Setup issue](https://www.dolibarr.org/forum/t/dolibarr-setup-issue/25404)

<div class="topic-metadata">

**Author:** [@AnandJ](https://www.dolibarr.org/forum/u/AnandJ)\
**Replies:** 2\
**Last updated:** [April 3, 2025, 8:36am UTC](https://www.dolibarr.org/forum/t/dolibarr-setup-issue/25404 "2025-04-03T08:36:17Z")

</div>

Hello Guys. I have installed dolibarr on debian nginx with ZIP file. I have finished installation successfully But at then END of step 5 its not asking to login back to home. If i write the URL manually domain.com/admi…

---

## [Dolibarr for several users on the same database](https://www.dolibarr.org/forum/t/dolibarr-for-several-users-on-the-same-database/6915)

<div class="topic-metadata">

**Author:** [@Medgoal](https://www.dolibarr.org/forum/u/Medgoal)\
**Replies:** 9\
**Last updated:** [April 3, 2025, 8:33am UTC](https://www.dolibarr.org/forum/t/dolibarr-for-several-users-on-the-same-database/6915 "2025-04-03T08:33:03Z")

</div>

Hello everybody, I am new to this ERP/CRM thing, but I want to use it for my company. I just have a question about Dolibarr. If I have several users in the company that I want to use Dolibarr from different computers but…

---

## [HOWTO: LDAP + ActiveDirectory instructions (with authentication) for Dolibarr 12](https://www.dolibarr.org/forum/t/howto-ldap-activedirectory-instructions-with-authentication-for-dolibarr-12/19541)

<div class="topic-metadata">

**Author:** [@jgrxd](https://www.dolibarr.org/forum/u/jgrxd)\
**Replies:** 2\
**Last updated:** [March 31, 2025, 8:23am UTC](https://www.dolibarr.org/forum/t/howto-ldap-activedirectory-instructions-with-authentication-for-dolibarr-12/19541 "2025-03-31T08:23:40Z")

</div>

This took awhile to figure out, so I’ll document it here. OS: Ubuntu 20.04 Dolibarr Version: 12.0.3 Steps: first you need to make sure you have php-ldap installed at your OS level: sudo apt-get install php-ldap\` …

---

## [Tat" Not Appearing in Devis - Need Assistance](https://www.dolibarr.org/forum/t/tat-not-appearing-in-devis-need-assistance/30160)

<div class="topic-metadata">

**Author:** [@Yassine](https://www.dolibarr.org/forum/u/Yassine)\
**Replies:** 1\
**Last updated:** [March 28, 2025, 6:40am UTC](https://www.dolibarr.org/forum/t/tat-not-appearing-in-devis-need-assistance/30160 "2025-03-28T06:40:17Z")

</div>

I’m experiencing an issue in Dolibarr where the Etat (status) does not appear in my devis (quotation). The Etat for commandes, factures, and livraisons are working fine, but when I create and validate a devis and clic…

---

## [Website module, website root path](https://www.dolibarr.org/forum/t/website-module-website-root-path/30115)

<div class="topic-metadata">

**Author:** [@pascalprogrammer](https://www.dolibarr.org/forum/u/pascalprogrammer)\
**Replies:** 2\
**Last updated:** [March 24, 2025, 7:26am UTC](https://www.dolibarr.org/forum/t/website-module-website-root-path/30115 "2025-03-24T07:26:37Z")

</div>

Hello, I’m a web developer and new with Dolibarr, but I like it. I’m sorry, I speak a little English. My problem: I have a domain name with shared hosting. For example: example.com The example.com domain root path i…

---

## [Recordnotfound Error when modifying/accessing entries](https://www.dolibarr.org/forum/t/recordnotfound-error-when-modifying-accessing-entries/30136)

<div class="topic-metadata">

**Author:** [@Lovelace23](https://www.dolibarr.org/forum/u/Lovelace23)\
**Replies:** 0\
**Last updated:** [March 24, 2025, 2:02am UTC](https://www.dolibarr.org/forum/t/recordnotfound-error-when-modifying-accessing-entries/30136 "2025-03-24T02:02:20Z")

</div>

\------------------------------------------------------------------------------------- DOLIBARR ENVIRONMENT - Version: \[21.0\] - Operating System: \[Ubuntu 24.04.2\] - Web Server: \[Apache 2\] - PHP: …

---

## [API key scrambled after database password change, or from v20.0.2 to v20.0.4?](https://www.dolibarr.org/forum/t/api-key-scrambled-after-database-password-change-or-from-v20-0-2-to-v20-0-4/30110)

<div class="topic-metadata">

**Author:** [@jonbendtsen](https://www.dolibarr.org/forum/u/jonbendtsen)\
**Replies:** 4\
**Last updated:** [March 22, 2025, 4:39pm UTC](https://www.dolibarr.org/forum/t/api-key-scrambled-after-database-password-change-or-from-v20-0-2-to-v20-0-4/30110 "2025-03-22T16:39:06Z")

</div>

hey So I experienced that 2 of my users API key was completely scrambled, meaning I had to generate new keys. No passwords has changed, only the API key. This might be after I either changed the database password, or i…

---

## [First setup HTTP 500 error](https://www.dolibarr.org/forum/t/first-setup-http-500-error/30079)

<div class="topic-metadata">

**Author:** [@itpionier](https://www.dolibarr.org/forum/u/itpionier)\
**Replies:** 2\
**Last updated:** [March 18, 2025, 1:36pm UTC](https://www.dolibarr.org/forum/t/first-setup-http-500-error/30079 "2025-03-18T13:36:37Z")

</div>

I am struggling with HTTP 500 errors in Setup\>Company/Organization and Setup\>Display. No problems in the other Setup menus. In both it is the same behavior: Fill a form: this takes time Click save \> HTTP 500 Click bro…

---

## [Howto change Dolibarr database password](https://www.dolibarr.org/forum/t/howto-change-dolibarr-database-password/30101)

<div class="topic-metadata">

**Author:** [@jonbendtsen](https://www.dolibarr.org/forum/u/jonbendtsen)\
**Replies:** 0\
**Last updated:** [March 16, 2025, 8:31pm UTC](https://www.dolibarr.org/forum/t/howto-change-dolibarr-database-password/30101 "2025-03-16T20:31:53Z")

</div>

In case anyone ever needs to change the contents of conf.php and especially the passwords here’s how I did it and upgraded from v20.0.2 to v20.0.4 stop and remove dolibarr container enter mariadb container and connect …

---

## [Help Needed: Using DOLI\_ENABLE\_MODULES in Docker Installation](https://www.dolibarr.org/forum/t/help-needed-using-doli-enable-modules-in-docker-installation/29945)

<div class="topic-metadata">

**Author:** [@Tiritibambix](https://www.dolibarr.org/forum/u/Tiritibambix)\
**Replies:** 4\
**Last updated:** [March 16, 2025, 5:31pm UTC](https://www.dolibarr.org/forum/t/help-needed-using-doli-enable-modules-in-docker-installation/29945 "2025-03-16T17:31:38Z")

</div>

Hello Dolibarr Community, I am trying to set up Dolibarr using Docker and I’m having trouble getting the DOLI\_ENABLE\_MODULES variable to work correctly. I have specified the following modules in my Docker setup: DOLI\_E…

---

## ["NOSUCH" database columns errors](https://www.dolibarr.org/forum/t/nosuch-database-columns-errors/30092)

<div class="topic-metadata">

**Author:** [@drusso](https://www.dolibarr.org/forum/u/drusso)\
**Replies:** 3\
**Last updated:** [March 13, 2025, 9:32am UTC](https://www.dolibarr.org/forum/t/nosuch-database-columns-errors/30092 "2025-03-13T09:32:02Z")

</div>

21.0.0. Running on an Ubuntu 22.04.4 (Digital Ocean VPS). Upgraded from 20.0.4. I am discovering that my database in mysql is missing all sorts of columns from various table. The issue is that I don’t know what I don’t k…

---

## [migration from shared to vps](https://www.dolibarr.org/forum/t/migration-from-shared-to-vps/16777)

<div class="topic-metadata">

**Author:** [@sajeel](https://www.dolibarr.org/forum/u/sajeel)\
**Replies:** 8\
**Last updated:** [March 13, 2025, 6:44am UTC](https://www.dolibarr.org/forum/t/migration-from-shared-to-vps/16777 "2025-03-13T06:44:51Z")

</div>

i wish to change my hosting from shared to vps server how can i backup and migrate to new server

---

## [Cannot login after install of 21.0](https://www.dolibarr.org/forum/t/cannot-login-after-install-of-21-0/30088)

<div class="topic-metadata">

**Author:** [@strk](https://www.dolibarr.org/forum/u/strk)\
**Replies:** 0\
**Last updated:** [March 11, 2025, 11:10pm UTC](https://www.dolibarr.org/forum/t/cannot-login-after-install-of-21-0/30088 "2025-03-11T23:10:11Z")

</div>

I’ve just installed 21.0 branch, but the username/password combination don’t seem to work. How can I debug it ? Are there commandline tools to change the admin password ?

---

## [Setup dolibarr to generate ODT to PDF](https://www.dolibarr.org/forum/t/setup-dolibarr-to-generate-odt-to-pdf/22112)

<div class="topic-metadata">

**Author:** [@VincentKun](https://www.dolibarr.org/forum/u/VincentKun)\
**Replies:** 12\
**Last updated:** [March 5, 2025, 1:23am UTC](https://www.dolibarr.org/forum/t/setup-dolibarr-to-generate-odt-to-pdf/22112 "2025-03-05T01:23:51Z")

</div>

Hi, i had currently installed dolibarr into my nas synlogy virtual web station, can anyone teach me step by step on how i can make dolibarr to generate odt to pdf. as im using odt template. thank you

---

## [Problem setting when entering the call dolibarr page during installation](https://www.dolibarr.org/forum/t/problem-setting-when-entering-the-call-dolibarr-page-during-installation/30023)

<div class="topic-metadata">

**Author:** [@botenadmin](https://www.dolibarr.org/forum/u/botenadmin)\
**Replies:** 3\
**Last updated:** [February 25, 2025, 8:21am UTC](https://www.dolibarr.org/forum/t/problem-setting-when-entering-the-call-dolibarr-page-during-installation/30023 "2025-02-25T08:21:36Z")

</div>

Hello, I hope you’re well. Could you please tell me the reason behind this issue and how to resolve it? Is it only possible to delete the installed Dolibarr and reinstall it, or is there another solution? Thank you …

---

## [PHP Version too high. Version 8.2.0 or lower is required](https://www.dolibarr.org/forum/t/php-version-too-high-version-8-2-0-or-lower-is-required/30010)

<div class="topic-metadata">

**Author:** [@GoZippy](https://www.dolibarr.org/forum/u/GoZippy)\
**Replies:** 1\
**Last updated:** [February 21, 2025, 9:49pm UTC](https://www.dolibarr.org/forum/t/php-version-too-high-version-8-2-0-or-lower-is-required/30010 "2025-02-21T21:49:48Z")

</div>

Need help to get 20.0.4 to run with secure php setup not years old php versions. Fresh install. Running first run install script. When will install I am told I have to use a 2 year old version of PHP which has been fixe…

---

## [Stuck at install step from browser](https://www.dolibarr.org/forum/t/stuck-at-install-step-from-browser/29991)

<div class="topic-metadata">

**Author:** [@cahsobo](https://www.dolibarr.org/forum/u/cahsobo)\
**Replies:** 2\
**Last updated:** [February 20, 2025, 10:49pm UTC](https://www.dolibarr.org/forum/t/stuck-at-install-step-from-browser/29991 "2025-02-20T22:49:57Z")

</div>

Hello, I have a problem with installing dolibar via dolideb package. the deb package was installed fine. but when i open localhost/dolibarr/install, it gave me something like this: \* Copyright (C) 2004-2010 Laurent Des…

[Previous page](https://www.dolibarr.org/forum/c/installing-my-dolibarr/6.md)

[Next page](https://www.dolibarr.org/forum/c/installing-my-dolibarr/6.md?page=2)
