# Dolibarr 14.0.4 Invoice payment not working

**URL:** <https://www.dolibarr.org/forum/t/dolibarr-14-0-4-invoice-payment-not-working/21562>\
**Category:** Using my Dolibarr\
**Tags:** v14\
**Created:** [December 7, 2021, 11:56am UTC](https://www.dolibarr.org/forum/t/dolibarr-14-0-4-invoice-payment-not-working/21562 "2021-12-07T11:56:59Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![Davy](https://www.dolibarr.org/forum/letter_avatar_proxy/v4/letter/d/e495f1/32.png) [@Davy](https://www.dolibarr.org/forum/u/Davy)\
**Post date:** [December 7, 2021, 11:56am UTC](https://www.dolibarr.org/forum/t/dolibarr-14-0-4-invoice-payment-not-working/21562/1 "2021-12-07T11:56:59Z")

</div>

Payment of a customer invoice is not working anymore in version 14.0.4. After filling in the paid amount and press “Pay” it returns an ERROR 500  
Did anyone have this problem and how can it be solved?

/erp/htdocs/compta/paiement.php

Regards,  
Davy

---

<div class="post-metadata">

**Author:** ![ksar](https://www.dolibarr.org/forum/user_avatar/www.dolibarr.org/ksar/32/514_2.png) [@ksar](https://www.dolibarr.org/forum/u/ksar)\
**Post date:** [December 7, 2021, 12:00pm UTC](https://www.dolibarr.org/forum/t/dolibarr-14-0-4-invoice-payment-not-working/21562/2 "2021-12-07T12:00:37Z")

</div>

Hello,

Error 500 = PHP error =\> Verify the logs

---

<div class="post-metadata">

**Author:** ![Davy](https://www.dolibarr.org/forum/letter_avatar_proxy/v4/letter/d/e495f1/32.png) [@Davy](https://www.dolibarr.org/forum/u/Davy)\
**Post date:** [December 7, 2021, 12:35pm UTC](https://www.dolibarr.org/forum/t/dolibarr-14-0-4-invoice-payment-not-working/21562/3 "2021-12-07T12:35:10Z")

</div>

Where can I verify the logs?  
I just found out that the settings/modules returns a blank window as well

---

<div class="post-metadata">

**Author:** ![ksar](https://www.dolibarr.org/forum/user_avatar/www.dolibarr.org/ksar/32/514_2.png) [@ksar](https://www.dolibarr.org/forum/u/ksar)\
**Post date:** [December 7, 2021, 12:56pm UTC](https://www.dolibarr.org/forum/t/dolibarr-14-0-4-invoice-payment-not-working/21562/4 "2021-12-07T12:56:34Z")

</div>

Don’t know, how and where dolibarr is installed ?

Blank windows on settings/modules can also come from an external module, can you remove them all ?  
What PHP version are you using ?

---

<div class="post-metadata">

**Author:** ![Davy](https://www.dolibarr.org/forum/letter_avatar_proxy/v4/letter/d/e495f1/32.png) [@Davy](https://www.dolibarr.org/forum/u/Davy)\
**Post date:** [December 7, 2021, 2:12pm UTC](https://www.dolibarr.org/forum/t/dolibarr-14-0-4-invoice-payment-not-working/21562/5 "2021-12-07T14:12:36Z")

</div>

Hello, I am using PHP 8.0.13.

Dolibarr is installed on my webspace under /erp/htdocs. I have been upgrading for several years. Uploading the new dolibarr files and run the install. Only since upgrade to version 14 there are some problems. But only discovered several issues today.  
All external modules have been removed. Problem still persists.

- erp/htdocs/admin/modules.php?mainmenu=home = blank page
- erp/htdocs/admin/dict.php?mainmenu=home = ERROR 500
- After some testing I found out that only invoices from a specific customer cannot be paid and return an ERROR 500

---

<div class="post-metadata">

**Author:** ![ksar](https://www.dolibarr.org/forum/user_avatar/www.dolibarr.org/ksar/32/514_2.png) [@ksar](https://www.dolibarr.org/forum/u/ksar)\
**Post date:** [December 7, 2021, 3:09pm UTC](https://www.dolibarr.org/forum/t/dolibarr-14-0-4-invoice-payment-not-working/21562/6 "2021-12-07T15:09:47Z")

</div>

Probleme is this :

> [@Davy](#):
>
> PHP 8.0.13.

Dolibarr V14 is not compatible PHP V8.  
Need 7.4 maximum

---

<div class="post-metadata">

**Author:** ![Davy](https://www.dolibarr.org/forum/letter_avatar_proxy/v4/letter/d/e495f1/32.png) [@Davy](https://www.dolibarr.org/forum/u/Davy)\
**Post date:** [December 7, 2021, 3:29pm UTC](https://www.dolibarr.org/forum/t/dolibarr-14-0-4-invoice-payment-not-working/21562/7 "2021-12-07T15:29:12Z")

</div>

Well, Thanks for your help.  
That was the problem. I activated PHP 7.4 and all works fine again.

Cheers  
Davy

---

<div class="post-metadata">

**Author:** ![ALOHA\_WS](https://www.dolibarr.org/forum/letter_avatar_proxy/v4/letter/a/a183cd/32.png) [@ALOHA\_WS](https://www.dolibarr.org/forum/u/ALOHA_WS)\
**Post date:** [December 11, 2021, 9:38am UTC](https://www.dolibarr.org/forum/t/dolibarr-14-0-4-invoice-payment-not-working/21562/8 "2021-12-11T09:38:06Z")

</div>

hello,  
User since a few years with Dolibarr 13 for a french company ( invoices and accounting ), i would like to use Dolibarr for an Irish ltd company, but i don’t know the basis requirements for accounting in Ireland.  
Could you tell me what i need to install for accounting, because i suppose that except adjusting VAT and some parameters, there are no change for invoices !  
Thanks  
DL
