# Help Needed: Using DOLI\_ENABLE\_MODULES in Docker Installation

**URL:** <https://www.dolibarr.org/forum/t/help-needed-using-doli-enable-modules-in-docker-installation/29945>\
**Category:** Installing my Dolibarr\
**Tags:** Core-Modules\
**Created:** [February 8, 2025, 9:38pm UTC](https://www.dolibarr.org/forum/t/help-needed-using-doli-enable-modules-in-docker-installation/29945 "2025-02-08T21:38:08Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Tiritibambix](https://www.dolibarr.org/forum/letter_avatar_proxy/v4/letter/t/da6949/32.png) [@Tiritibambix](https://www.dolibarr.org/forum/u/Tiritibambix)\
**Post date:** [February 8, 2025, 9:38pm UTC](https://www.dolibarr.org/forum/t/help-needed-using-doli-enable-modules-in-docker-installation/29945/1 "2025-02-08T21:38:08Z")

</div>

Hello Dolibarr Community,

I am trying to set up Dolibarr using Docker and I’m having trouble getting the `DOLI_ENABLE_MODULES` variable to work correctly. I have specified the following modules in my Docker setup:

```auto
DOLI_ENABLE_MODULES: MODSOCIETE,MODFACTURE,MODBANQUE,MODCOMPTABILITE,SERVICES,MODDBADMIN

```

However, after the installation, these modules are not active. I am not sure if I am using the correct module names or if there is a specific way to implement them.

Could someone please guide me on the correct usage of the `DOLI_ENABLE_MODULES` variable and confirm if the module names I am using are accurate? Any help or suggestions would be greatly appreciated.

Thank you in advance!

---

<div class="post-metadata">

**Author:** ![jonbendtsen](https://www.dolibarr.org/forum/letter_avatar_proxy/v4/letter/j/977dab/32.png) [@jonbendtsen](https://www.dolibarr.org/forum/u/jonbendtsen)\
**Post date:** [February 9, 2025, 9:08am UTC](https://www.dolibarr.org/forum/t/help-needed-using-doli-enable-modules-in-docker-installation/29945/2 "2025-02-09T09:08:48Z")

</div>

hey

what does your docker log say when you start it for setup?

> <https://github.com/Dolibarr/dolibarr/issues/31007>
>
> \### Bug
> 
> BUG: DOLI\_ENABLE\_MODULES expects Capital Letters In The Module List, bu…t api delivers output in lowercase
> 
> 
> \### Dolibarr Version
> 
> 19.0.3 container image
> 
> \### Environment PHP
> 
> 19.0.3 container image
> 
> \### Environment Database
> 
> mariadb lts-noble container image
> 
> \### Steps to reproduce the behavior and expected behavior
> 
> The documentation for \`DOLI\_ENABLE\_MODULES\` says:
> 
> \`\`\`
> Comma-separated list of modules to be activated at install. modUser will always be activated. (Ex: Societe,Facture,Stock)
> \`\`\`
> 
> but when I extract the module list from \`/api/index.php/setup/modules\` I get a list with only lower case.
> 
> \`\`\`
> \[
> "accounting",
> "adherent",
> "agenda",
> "api",
> "banque",
> "facture",
> "societe",
> "tax",
> "user"
> \]
> \`\`\`
> 
> I wish that these 2 were identical
> 
> 
> \### Attached files
> 
> \_No response\_

---

<div class="post-metadata">

**Author:** ![Tiritibambix](https://www.dolibarr.org/forum/letter_avatar_proxy/v4/letter/t/da6949/32.png) [@Tiritibambix](https://www.dolibarr.org/forum/u/Tiritibambix)\
**Post date:** [February 9, 2025, 9:49am UTC](https://www.dolibarr.org/forum/t/help-needed-using-doli-enable-modules-in-docker-installation/29945/3 "2025-02-09T09:49:27Z")

</div>

Hello,

Thank you for your answer.  
So the logs say

```auto
Activating module MODSOCIETE ... FAILED. Unable to load module. Be sure to check the case
Activating module MODFACTURE ... FAILED. Unable to load module. Be sure to check the case
Activating module MODBANQUE ... FAILED. Unable to load module. Be sure to check the case
Activating module MODCOMPTABILITE ... FAILED. Unable to load module. Be sure to check the case
Activating module SERVICES ... FAILED. Unable to load module. Be sure to check the case
Activating module MODDBADMIN ... FAILED. Unable to load module. Be sure to check the case

```

So they are case sensitive, But I can’t find a precise reference in the documentation as to how to write the name of the modules in my variables.

I tried all uppercase, camelCase, and all lowercase …

---

<div class="post-metadata">

**Author:** ![Tiritibambix](https://www.dolibarr.org/forum/letter_avatar_proxy/v4/letter/t/da6949/32.png) [@Tiritibambix](https://www.dolibarr.org/forum/u/Tiritibambix)\
**Post date:** [February 9, 2025, 10:20am UTC](https://www.dolibarr.org/forum/t/help-needed-using-doli-enable-modules-in-docker-installation/29945/4 "2025-02-09T10:20:02Z")

</div>

Ok so the issue you linked to was helpful.

This comment in particular:

> the output is produced with this input from var file
> 
> ```auto
> dolibarr_modules: >'Accounting,Adherent,Agenda,Api,banque,barcodecommande,cron,eventorgani>zation,expensereport,export,facture,gravatar,import,notification,product,projet,p>ropal,service,socialnetworks,society,stock,stripe,paypal,syslog,takepos,tax,user>,variants,webhook'
> 
> ```

BUT, it was not `society` but `societe`

I wish there were clearer instructions about this.

Again, thanks for your help.

---

<div class="post-metadata">

**Author:** ![Arano](https://www.dolibarr.org/forum/letter_avatar_proxy/v4/letter/a/9d8465/32.png) [@Arano](https://www.dolibarr.org/forum/u/Arano)\
**Post date:** [March 16, 2025, 5:31pm UTC](https://www.dolibarr.org/forum/t/help-needed-using-doli-enable-modules-in-docker-installation/29945/5 "2025-03-16T17:31:38Z")

</div>

For those that will come later, the expected name is the name of the description file of the module.

Before anything else, be sure to have set the company name and company country with DOLI\_COMPANY\_NAME and DOLI\_COMPANY\_COUNTRYCODE. Enabling modules without that can break installation.

The files are like `modName.class.php`, as `modUser.class.php`, `modDoliCalc.class.php` or `modFacture.class.php`. Remove the “mod” and the “.class.php” parts and you have the name.

These files are located at `DOL_ROOT/core/modules/modName.class.php` for core modules and `DOL_ROOT/some_name/core/modules/modName.class.php` for custom modules.

You can find all your modules descriptor files with :  
`find DOL_ROOT/ -name 'mod*.class.php'`
