Associate products to supplier

Hello,

When I am trying to associate a product to a supplier I receive the following error:

Unknown column ‘unitcharges’ in ‘field list’ sql=UPDATE llx_product_fournisseur_price SET fk_user = 1 , ref_fourn = ‘test001’, price = 1, quantity = 1, remise_percent = 10, remise = 0, unitprice = 1, unitcharges = 0, fk_availability = 0, entity = 1, tva_tx = 0, default_vat_code=null, info_bits = 0, charges = 0, delivery_time_days = 10, supplier_reputation = ‘FAVORITE’ WHERE rowid = 24

Also:

Dolibarr has detected a technical error.
This information can be useful for diagnostic purposes (you can set option $dolibarr_main_prod to ‘1’ to remove such notices):
Date: 20200729150351
Dolibarr: 7.0.0
Level of features: 0
PHP: 7.0.33
Server: LiteSpeed
OS: Linux server62.romania-webhosting.com 3.10.0-962.3.2.lve1.5.27.el7.x86_64 #1 SMP Sat Nov 30 02:18:52 EST 2019 x86_64
UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.89 Safari/537.36

Requested URL: /dolibarr/htdocs/product/fournisseurs.php?id=961
Referer: http://erp.allengra.eu/dolibarr/htdocs/product/fournisseurs.php?id=961&action=add_price&mainmenu=home
Menu manager: auguria_menu.php

Database type manager: mysqli
Latest database access request error: SELECT s.nom as supplier_name, s.rowid as fourn_id, pfp.rowid as product_fourn_pri_id, pfp.ref_fourn, pfp.fk_product as product_fourn_id, pfp.fk_supplier_price_expression, pfp.price, pfp.quantity, pfp.unitprice, pfp.remise_percent, pfp.remise, pfp.tva_tx, pfp.fk_availability, pfp.charges, pfp.unitcharges, pfp.info_bits, pfp.delivery_time_days, pfp.supplier_reputation FROM llx_product_fournisseur_price as pfp, llx_societe as s WHERE pfp.entity IN (1) AND pfp.fk_soc = s.rowid AND s.status=1 AND pfp.fk_product = 961 ORDER BY s.nom ASC
Return code for latest database access request error: DB_ERROR_NOSUCHFIELD
Information for latest database access request error: Unknown column ‘pfp.unitcharges’ in ‘field list’

Help, please.

Thank you very much!

Hi,

A good start is to do the update of your old Dolibarr version.

At least apply all the FIX with the 7.0.5

Hello,

I apologize but I can’t do that because I have some modules which are working only on 7.0.0.

Thank you very much!

Hi,

If they are working with 7.0.0, they will work with 7.0.5

Hello,

I looked into the upgrade methods and downloaded the 7.0.5 version but there is a change to lose the current settings even if I backup the DB, is there any way to do it safely without any data lose?

Thank you very much!

Hi,

Normally it is safe.
Just make a back-up to be safe before.

Hello,

The person who took care of the ERP before me said that he installed some modules which work only on 7.0.0 and if I upgrade it to 7.0.5 they won’t work, could you please help me with the problem I listed above?

Thank you very much!

Hi,

I don’t believe it.

Your error is most probably fixed by the evolution from V7.0.0 to V7.0.5, so I will not spend time to try to understand your issue