Cannot find htdocs/conf/conf.php

First of all, let me say that Dolibarr seems to be an awsome crm from what I have seen so far. I am truly impressed and thankful to everyone who has contributed to the project.

I have installed dolibarr ver 17.0.0 via Softaculous provided by my webhotel. I have started to configure the installation and so far everything seems to be working just fine. The only thing is a warning message that is displayed on my dashboard. It is pasted below:

" Warning, your config file (htdocs/conf/conf.php ) can be overwritten by the web server. This is a serious security hole. Modify permissions on file to be in read only mode for operating system user used by Web server. If you use Windows and FAT format for your disk, you must know that this file system does not allow to add permissions on file, so can’t be completely safe. This security warning will remain active as long as the vulnerability is present."

I cannot find a htdocs folder. I do however find conf/conf.php in the folder I defined for Dolibarr during installation. The permission for the conf.php was 0777. I have changed it to 0644. I have logged out, reloaded the page and logged in again. The warning message is still there.

Any tips on what I do wrong?


How do you fiz this issue?
I my environmente show same error!


I don’t know if you have a response since this time, but I had the same problem on a Softaculous install and I put a chmod 444 on ./conf/conf.php from the root directory where dolibarr is installed.


Hi Marc,

Thanks for your reply.

I have actually paused Dolibarr for now and moved ahead with the open source version of vtiger. The lack of response in this forum made me rethink.


Hi guys,

Just for the update, i got the same error, i have to

chmod 644 /etc/dolibarr/conf.php

I don’t know why those file can’t stay in /var/www but it’s making me mad. (some are stored in /usr/share/dolibarr) :face_vomiting:


If you installed the debian package, you need to know that a debian package follows some rules and these rules tell to split the files with directory like /etc, /usr/share, /var/www,…

Errr thats why !
I wasn’t used to install debian package :wink: