change url name

Good day,

Please, can someone tell me how do i change the url name from localhost/dolibarr to localhost/customname.

I appreciate any help.


What OS are you using?

On debian/ubuntu you have the file /etc/apache2/conf-available/dolibarr.conf where you change the alias option. After restarting apache with “systemctl restart apache2”. The change is loaded.

Also you need to change in /etc/dolibarr/conf.php the option dolibarr_main_url_root, this tells the correct setting to Dolibarr.

Dear michielp,

Thanks for reply. iam using Windows OS. Could you tell me the file folder ?

Best Regards,

Dear michielp,

I have made the change sugested but without sucess. Please see attached the printscreen of changes that i made.

Could you please help?


I’m sorry I don’t see any screenshot?

Good day michielp,

please find the screenshot

Hi, This is what I see:


Hi in one of the apache files you have the option Alias, like on my system:
Alias /dolibarr /usr/share/dolibarr/htdocs

Also it is possible that it is loaded with DocumentRoot.

Both options tels apache where it can finds the Dolibarr application. This directory option tells what the apache rights are.

i have change the dolibarr to conta on document_Root but it still not working

Perhaps I should asked that earlier but what is the error that you get?

This the error i have

What is the current DocumentRoot? Also what happens when you open the directory htdocs?

// Take a look at conf.php.example file for an example of conf.php file
// and explanations for all possibles parameters.

when i clik on htdocs it look diferent . take look the diference now and before i made changes


Before changes it was like that

Any ideal please ???

You send the dolibarr dolibarr_main_document_root settings, It wasn’t very clear, but I meant the apache2 settings.

What is the apache2 DocumentRoot?

Oh ! sorry, the apache documentroot is :::: DocumentRoot “c:/contabilidade/www/”

please see the complete apache file

Pièces jointes :

iam sorry that was the alias

bellow the apache

httpd.txt (28.6 KB)