Data not saving after initial installation

We have installed Dolibarr 6.0.4 (we also tried 6.0.3 but wiht the same result) on PHP7 and NGINX.
The installation went fine and we set up the superadmin account without issue.
We can log in to the superadmin account, but when we enter any data in to the set up screens (such as company name), when we press save the screen refreshes but the fields are then blank again. The same thing happens with the dropdowns; we can click the dropdown, search for and select a record (Country for example), then the screen refreshes (I assume this should then return some other data to choose from), but it has blanked out selected dropdown.
I seem to be able to flick the “switch” sliders to turn on and off modules and this saves. The issue seems to be with places where I have to select data from lists or enter it in to text boxes.
Any thoughts on how to resolve this would be appreciated.

Install a different browser in it’s default settings and try again.

If this doesn’t work either, we’ll have to dig deeper.

Best regards

Thank you for the reply.

This isn’t user machine specific, it happens to all machines we have tried it on, so it looks to be a server configuration issue. We built the server on Ubuntu Server 16.04. That is using nginx/1.10.3 as the web server with PHP 7.0.22 FPM/FastCGI. The database is Percona which is a direct drop in replacement for MySQL (MySQL or MariaDB 5.7.19-17 in this instance). During installation of Dolibarr we needed to install a couple of extras on the server such as cURL as advised by the installation screens.

I wonder if the issue is related to a required PHP extension or other server dependency not yet installed / configured, but having read the installation page ( I cant see anything.

I am able to send over data from Admin Tools / About within Dolibarr if this would assist? (assuming you have a private message option). Or can give you access to the Dolibarr installation as it is public facing and without any data yet.

I note that under Users and Groups we get the following message:
Your PHP does not allow listing active sessions. Directory used to save sessions (/var/lib/php/sessions) might be protected (For example, by OS permissions or by PHP directive open_basedir).
However that save session location does have what looks to be current session information in it and the PHP set up doesnt have open_basedir set up.

Many thanks

A potential answer:

Best regards

Thank you for the suggestion. I note that the session path on the server is slightly different as it has an S on the end, but I have tried this:

chown -R nobody:nogroup /var/lib/php/sessions

and then restarting nginx, but it made no difference. I have also tried temporarily setting the folder and its contents to 777 permissions but this made no difference either.

I note that now the folder is owned by nobody:nogroup but with standard 755 / 644 permissions I can not log out or in ! The screen just refreshes. I can do this if I have them as 777 which implies to me that the owner is now incorrect.

In this folder I can see session data and that is showing with the owner www-data:www-data

So, I have tried the following which allows me to log in and out ok with the folders and file on standard permissions, but the issue with saving set up data remains:

chown -R www-data:www-data /var/lib/php/sessions
find /var/lib/php/sessions/ -type d -exec chmod 755 {} ;
find /var/lib/php/sessions/ -type f -exec chmod 644 {} ;

Would it help PM you some information from the Setup / Admin screens?

Many thanks Casati.

Pls check the data displayed from

Setup -> Admin tools ->

About Dolibarr
About Browser
About OS
About Web Server
About PHP
About Database

You can also send them as .txt file attachments to your reply - or use something like DropBox to make this info available.

Best regards

Hi Casati

Many thanks for this. I can get the information in the next day or so.

In the meantime I thought I would update on some progress I made. I tried removing NGINX from the server and installed Apache. The site works normally now. Does this help isolate a possible area to investigate?

Ideally we would like to retain NGINX as this lines up with other sortware installations we use.

Many thanks

Based on many decades of experience working in IT, I would recommend to stay with Apache, because"no muss, no fuss".

Be productive first with a tested system. Without further ado.
Then use your available spare time to setup another fresh test-server with nginx/percona/php7.

Best regards


we have now the same problem:

Dolibarr setup under Windows 10 - with Laragon (it’s like XAMPP).

Installation & login is okay (all green),
but company settings will not saved.

OS: Windows 10
Database: MySQL 5.7.19
PHP: 7.1.19
nginx: 1.14.0
Dolibarr: 8.0.1






QuickSettings=xdebug, max_execution_time, upload_max_filesize, post_max_size, memory_limit


I know this is super old, however we have seen issues in the current mySQL where the user is created but does not have the correct permissions to modify the database, we changed the conf.php to use the root username and password for the database and it works ok.

Not really sure what the problem is, but seems to be connected with the database being on the same machine as the HTTP server (localhost) and the use of “root” to create the database and user that Dolibarr uses.

This may not be the same as the issue above, but would stop data being written in to the database

you may experience one of the following symptoms:
When you save a new workbook file to the network drive, you receive an error message that is similar to the following
Your changes could not be saved to
‘BOOK1.XLS’, but were saved to a temporary document named ‘4CCA4100’. Close the existing document, then open the temporary document and save it under a new name.
4CCA4100 is a random eight-character alphanumeric string, and BOOK1.XLS is the name of the file you are saving.
When you save an existing workbook file to the network drive, the file appears to be saved with the name you typed in the
Save dialog box. However, when you open this file again from the network, your changes do not appear in the file. The file is actually saved to the network drive with a random file name that contains numbers and letters, such as 4CCA4100.