DB_ERROR_1118: ALTER TABLE llx_actioncomm ADD COLUMN reply_to varchar(255);

I used the deb distrubution on ubuntu when on update I’ve got the error:
Fout DB_ERROR_1118: ALTER TABLE llx_actioncomm ADD COLUMN reply_to varchar(255);
Row size too large. The maximum row size for the used table type, not counting BLOBs, is 8126. This includes storage overhead, check the manual. You have to change some columns to TEXT or BLOBs

Hello Dijkenbouwer,
Update from what version and which screen?
Kind regards.

Updated from dolibarr_12.0.4-4 to dolibarr_13.0.0-4.
Screen is the update screen when I return to dolibarr’s url after running the update.

I don’t know how you do your update, but if you do these steps, still a problem?

  1. make backup from backup database in admin tools in 12.
  2. do a seperate clean install of 13
  3. Make a new database and load database of 12.
  4. Connect database to 13.
  5. Do the update process and find out if the database is fine now.
    kind regards. Hans from Dolisupport.nl


Verify the database interclassing:

Ok, thanks for your tips. So I backupped SQL and Documents and removed Dolibarr. Installed the latest version 13.0.0-4 and restored db and documents. Also I installed phpmyadmin to check what happened in db. Then I saw that llx_actioncomm still not had a column reply_to. Then I did in the SQL-window of phpmyadmin: ALTER TABLE llx_actioncomm ADD COLUMN reply_to varchar(255); and there was no problem, so I think everything is ok. I only think it is strange that the extra column still not was available. But anyhow, my problem is solved.

hi guys, it is long time ago since you replied to this thread but I have the same error:

Dolibarr 16.0.3 upgraded to 17.0.3 on Ubuntu 20.04.6 LTS

do you have any idea?


Same as before, verify the inertclass of database and table llx_cronjob

1 Like

thanks for the reply!

I don’t know how to check this, but I see this on the installation procedure:
|Client charset|utf8|
|Client collation|utf8_general_ci|


Do you have phpmyadmin ?

Yes I saw that client side is OK, but at least some of your MYSQL tables utf8mb4_general_ci instead of utf8_general_ci

I’m not advanced user, how to check it?

I did the installation through DoliDeb

Ok, then we try step by step

First easy one that you can try : Launch in your browser the mysql repair script of Dolibarr
I get this

Not Found

The requested URL was not found on this server.

Apache/2.4.41 (Ubuntu) Server at Port 80

BTW I’ve installed phpmyadmin (I think so)

but I don’t know the credentials, root/password are not working

What is the URL to access Dolibarr ?

Credentials are in the file conf/conf.php of dolibarr


did it


click on dolibarrdebian database


1 Like

my man, you’re a legend!!!
everything is ok, doing some checks now but I don’t see any issues so far


1 Like