Documents directory doesn´t exist

I´m executing the first installation of dolibar on web hosting.
I copied the all files by ftp as per instructions.
I type on browser following address : and I was going to chck.php page.
I checked the all requirement are ok.
I clicked the button to move forward and I was going to fileconf.php page.
Here automatically some field are filled like:
Directory for Web Pages: /home/xxxxx/xxxxxxxxx/b11_18957543/
URL Root
But Directory where create documents is filled in this way …/…/documents.
I´m going to create the directory outside of web pages directory as instructions with following path: /home/xxxxx/xxxxxxxxx/b11_18957543/
I checkd that documents directory has write and read permission.
I fill the Database fields as per instructions and i mouve forward but I retrieve following error:
“The directory /home/xxxxx/xxxxxxxxx/b11_18957543/ doesnt exists. It is mandatory create this directory enabling the write web permission”.
So I don´t understand because directory exist on server on that path.

Some body have some tips to help ?

Thanking in advance


Hi to everibody,

I discovered from myself the mistake I needed to write not the full path but only the domain path in this way “…/”.

Thanks in any case.


I have exactly the same issue with Dolibarr 13.0.2 and 14.0.5 on Manjaro Linux.

My Directory where web pages are stored: /usr/share/webapps/dolibarr/htdocs

My Directory to store uploaded and generated documents: /usr/share/webapps/dolibarr/documents

I tried ownership root:http and http:http with 775, 775 and even 777. Non of them worked. Dolibarr keeps saying the directory doesn’t exist.

I tried to systemctl edit php-fpm.service and added the path to ReadWritePath. Did not help either. SElinux is not part of Manjaro, so it is also not the problem.

Does anyone have an idea, how to possibly fix this issue?