Dolibarr ERROR on replenishment under Warehouses

Hi guys,

I’m new to this dolibarr, and we are going to use this for corporate use. However, I got this error upon clicking replenishment under warehouses:

Dolibarr has detected a technical error.
This information can be useful for diagnostic purposes (you can set option $dolibarr_main_prod to ‘1’ to remove such notices):
Date: 20211125201729
Dolibarr: 14.0.3 - https://www.dolibarr.org
Level of features: 0
PHP: 7.3.31
Server: LiteSpeed
OS: Linux sg-nme-web594.main-hosting.eu 4.18.0-305.19.1.lve.el7h.x86_64 #1 SMP Thu Sep 23 11:57:48 UTC 2021 x86_64
UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/96.0.4664.45 Safari/537.36

Requested URL: /product/stock/replenish.php?mainmenu=products
Referer:
Menu manager: eldy_menu.php

Modules/Applications: user, api, fournisseur, supplier_proposal, incoterm, facture, tax, salaries, loan, don, banque, paymentbybanktransfer, prelevement, margin, product, accounting, reception, adherent, stock, holiday, expensereport, variants, recruitment, bom, mrp, societe, propal, projet, commande, expedition, resource, ecm, contrat, externalrss, import, ficheinter, export, modulebuilder, ticket, opensurvey, takepos, agenda, categorie, mailing, emailcollector, cron, receiptprinter, printing
Database type manager: mysqli
Latest database access request error: SELECT p.rowid, p.ref, p.label, p.description, p.price, p.price_ttc, p.price_base_type, p.fk_product_type, p.tms as datem, p.duration, p.tobuy, p.desiredstock, p.seuil_stock_alerte, p.desiredstock as desiredstockcombined, p.seuil_stock_alerte as seuil_stock_alertecombined, s.fk_product, SUM(IF(s.reel IS NULL,0,s.reel)) as stock_physique FROM k8c0_product as p LEFT JOIN k8c0_product_stock as s ON p.rowid = s.fk_product AND s.fk_entrepot IN () WHERE p.entity IN (1) AND p.tobuy = 1 GROUP BY p.rowid, p.ref, p.label, p.description, p.price, p.price_ttc, p.price_base_type,p.fk_product_type, p.tms, p.duration, p.tobuy, p.desiredstock, p.seuil_stock_alerte, s.fk_product HAVING ((p.desiredstock >= 0 AND (p.desiredstock > SUM(IF(s.reel IS NULL,0,s.reel)))) OR (p.seuil_stock_alerte >= 0 AND (p.seuil_stock_alerte > SUM(IF(s.reel IS NULL,0,s.reel))))) ORDER BY p.ref ASC LIMIT 26
Return code for latest database access request error: DB_ERROR_SYNTAX
Information for latest database access request error: You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ‘) WHERE p.entity IN (1) AND p.tobuy = 1 GROUP BY p.rowid, p.ref, p.label, p.d…’ at line 1

I’ve tried searching around but can’t find a good solution. Any thoughts on this guys?

Try the update to V14. 0.4

1 Like

Agreed, I feel 14.0.3 caused quite a few issues… seems true, looking at the large number of fixes in 14.0.4

When I uploaded and extracted the new version of Dolibarr, the version doesn’t change, any thoughts guys?

Hello,

The only possibility is that you don’t upload it to the right folder

hi, I don’t know if I’m doing it right so, I downloaded the zip file, and extracted it on

/home/domains/site.com/

then using site.com/install/ to start the process.

I’m doing it right yes?

Hello,

On the Dolibarr archive, the application is on the htdocs folder, that seems not exist on your setup

actually, the htdocs is present there sir.

So it should be: /home/domains/site.com/htdocs/install

hi, I this is how the directory of my site looks like:

/home/domains/site.com/public_html/

shoud I extract the contents of the zip file to:

/home/domains/site.com/

cause I tried every possible ways to upgrade, but still it doesn’t upgrade.

the contents of the

htdocs

folder should be uploaded to

/home/domains/site.com/public_html/

hi,

Thanks sir, this solves my problem :slight_smile:
I was able to update the version and the errors gone.

1 Like