Dolibarr online signature link showing "localhost" - how to change it?

Hi everyone,
I have Dolibarr 17.0.2 running in a docker container, on a Synology NAS.
I can access Dolibarr from a specific url ( and everything works just fine.

In the commercial proposals module, I can find an online signature link: this link does not work because it is pointing to http://localhost/etc.
How can I change this default value with my custom url?

I’ve tried stopping the container, changing the DOLI_URL_ROOT with my synology url, but nothing changed at the container reboot.

What am I missing? Any ideas?


Hello :slight_smile:

in conf directory, in your conf.php file can you check the “$dolibarr_main_url_root” value

Good continuation

thanks for the reply. New noob question incoming :sweat_smile:: the htdocs folder is not mapped. How can I access it in order to download the file, update it, and overwrite it in the container folder?

Thanks for your question
Can you explain what you want to do, and can you give us some information about your install

Hi, thanks for the reply.
I solved the problem: I was searching a way to edit the conf.php file. I accessed the file via docker terminal, copied it in a mapped folder, downloaded it from the Synology file system, edited reuploaded and copied again in the correct folder via docker terminal.

Now everything works correctly.

Thanks everyone!!!