Emailing function

Hello all,

since 3 Month I am searching in the Internet about a Error I get when I try to send mails from Dolibarr.

The connection test to the server show the following:
Serververfügbarkeit testen
Server ist verfügbar unter der Adresse ssl://mail.ARCOR.DE auf Port 465
What say’s yes is working.

Then I try to send a Email form Dolibarr and I get the following Error:
Error
Error [120]: Ran into problems sending Mail. Response: 554 5.7.1 : Helo command rejected: EHLO invalid Error [120]: Ran into problems sending Mail. Response: 554 5.5.1 Error: no valid recipients Error [120]: Ran into problems sending Mail. Response: 221 2.7.0 Error: I can break rules, too. Goodbye.

My Configuration is like this.:
Method: Smtp soket lib
Host: mail.arcor.de
Port: Standard 465
my name
my password
TSL try yes or no
Main_Mail_Debug 1 in the log file is nothing important written.
does someone has a tip?

regards
Andreas

Which method do you use ?
“PHP mail” or “SMTP socket library” ?
Did you try with another smtp provider ?
What if you use the “Test sending” from page home - setup - email (not the “test server availbility”)

Hello a_schneider,

could you test with host mx.arcor.de instead of mail.arcor.de and tell what happend?

Regards

Hello planpc, Hello Eldy,

with mx.arcor.de (all other thinks still the same) I get this Error:
Server nicht verfügbar unter Adresse ssl://mx.ARCOR.DE auf Port 465 - Error 111 - Connection refused (the same with port 25 the Standard port for mx) But with TLS: No I get :confused:erver ist verfügbar unter der Adresse mx.ARCOR.DE auf Port 25
Because of this (from Arcor Home page):
[color=#440088]mx.arcor.de unterstützt keinen SSL-Zugriff über Port 465 (macht bei MX auch wenig Sinn), d.h. der Server ist nur über TLS auf Port 25 erreichbar und da wird nur TLS 1.x unterstützt.

mail.arcor.de unterstützt SMTP-Secure auf Port 465 und da werden laut sslscan folgende Cipher angeboten:

Accepted TLSv1 256 bits AES256-SHA
Accepted TLSv1 128 bits AES128-SHA
Accepted TLSv1 128 bits RC4-SHA[/color]

Sending than an Email I get this message:
Fehlschlag
Error [120]: Ran into problems sending Mail. Response: 503 5.5.1 Error: authentication not enabled Error [120]: Ran into problems sending Mail. Response: 502 5.5.2 Error: command not recognized Error [120]: Ran into problems sending Mail. Response: 502 5.5.2 Error: command not recognized Error [130]: Invalid Authentication Credentials.
But the Username and the Password are not changed.

To Eldy:
Methed is:Method: Smtp soket lib (SMTP Socket Libary)

until know I do not have another Email or smtp provider but I will try over the weekend.
What if you use the “Test sending” from page home - setup - email (not the “test server availbility”)
until Know I have not done it in another way. What happens is: I get a with page. (dolibarr/admin/mails.php)
May I have forgotten to set-up something in the right way?
Regards

I guess that dolibarr is not hosted on the same server that ARCOR.DE is, and you are trying to use arcor.de smtp server, am I right?

In that case maybe you must contact your hoster or server administrator to allow send email from the Dolibarr host IP, as this server only allow these ranges of IP to send email.(attached image of spf file, public info)

Hope it helps

Pièces jointes :

Now after one Week, without your help Mr or Ms PlanPc, it is working perfect with PHP mail. And it was easy to Implement.
It was not a problem with " not hosted on the same server that ARCOR.DE is"
It is also not a Problem with Dolibarr itself. It is just a Problem with the Bad documentation here “http://wiki.dolibarr.org/index.php/Prerequisite” Some requirements are missing.
If someone like to know how it is working send me an Email and I will help him or here to get Email with dolibarr working.

Hello, I have the same problem,
Error [120]: Ran into problems sending Mail. Response: 535 Incorrect authentication data Error [130]: Invalid Authentication Credentials.
Can you tellme how solve this?,

Hello,
I am also getting this error after updating dolibarr to 11 version as it was working flawlessly in the previous version.

Error [132]: STARTTLS connection failed. Error [121]: Couldn’t get mail server response codes Error [120]: Ran into problems sending Mail. Response:

Any help would be much appreciated.

Kind Regards,
Adnan

Hi, I saw your post, and I have the same problem in dolibarr, could you share the prerequisite information that the server needs to solve the error.
Greetings from Guatemala