Error when importing products

I have installed Dolibarr ver 10 and set up the company successfully. However I am getting this error when I try import products “Field 25: ‘’ is not a value found in field code of Measuring Units” I have set those fields to be Not Mandatory.

Help please.

[ following POST GUIDELINES no one will be able to help you properly[/url] screenshots would also help to understand your issue

- Version: [10.0.1]
- Operating System: [Linux CENTOS 7.6 kvm]
- Web Server: [Apache 2.4.41]
- PHP: [7.2.7]
- Database: [MySQL 5.7.27]
- URL(s): [/imports/import.php]

I’m facing the same issue.
In error message, the field “code” is mentioned, on the other hand in sample file downloaded field “Short Label” is mentioned.
In my import file I’m using fields “code” or “short_label” or even field “label”. in every case the import fails.
Th eabove is true in every kind of unit trying to import “p.length_units” , “p.surface_units” etc.

Any suggestions?

Regards, Dennis

It looks like you haven’t matched the fields properly in STEP 4

as you can see on the left side of the list “Fields in source file” there are black crosses with arrows at the beginning of each row. Drag and drop the “Fields in source file” to match the “Target fields in Dolibarr database”. Once you match them properly the import of products should go smoothly.
For more info about the import module, please visit
Good luck

Hi, you may have a look at
units are not properly handled when importing and a patch is proposed.
Regards, Marc

1 Like

I am facing the same problem (10.0.2) , with no unites and values for units inside the file.
Hopefully this will be solved in next release too (

Solved with 10.0.3 THANKS A LOT!!!

Pls note: Import template has changed