Fatal error: Maximum execution time of 900 seconds exceeded in C:\xampp\htdocs\dolibarr-12.0.2\

Hello,

When I try to install dolibarr 12.0.2 in my localhost I get this error message: **Fatal error : Maximum execution time of 900 seconds exceeded in “C:\xampp\htdocs\dolibarr-12.0.2\htdocs\core\db\mysqli.class.php” on line 275
I changed $cfg['ExecTimeLimit'] to 6000 & 0, but both did not work. My OS is windows 2010.

Please help,

Thanks

Hi,

To change the PHP max excution time you need to do it on php.ini

Thanks for your prompt reply. I did change it, unfortunately still the same error.
C:\xampp\htdocs\dolibarr-12.0.2\htdocs\core\db\mysqli.class.php on line 275

I uninstalled XAMPP, and installed WAMP server. Then I tried to install dolibarr 12.0.2 in to my localhost. I get the same error:
Fatal error: Maximum execution time of 900 seconds exceeded in C:\wamp64\www\dolibarr-12.0.2\htdocs\core\db\mysqli.class.php on line 275

I tried every option as advised on-line without any success.

Please help,

RESOLVED…
Change @set_time_limit(900) to 1800 in step2.php
Location : dolibarr-12.0.2/htdocs/install

1 Like

Thanks for feedback. Will be increased for 12.0.3

1 Like