Install.lock found even though it is not there

I am updating from 17.0.2 to 18.0.2. I have done the update process couple of times per year since 2013, so the prcess is pretty familiar. This is the first time the update fails!

After I have uploaded the files to the server, I initiate the update, but all I get is this:

"The application tried to self-upgrade, but the install/upgrade pages have been disabled for security (by the existence of a lock file install.lock in the dolibarr documents directory).

If an upgrade is in progress, please wait. If not, click on the following link. If you always see this same page, you must remove/rename the file install.lock in the documents directory.
Click here to go to your application"

Clicking the link starts the update again, so I’m stuck in the page. Install.lock has been removed from documents before the update. Any ideas what I might try?

Thanks for any input on the issue,

You may want to check if “install.lock” is in another directory [most likely in the htdocs directory]

I hope this helps.

Aaand there it was! I have always moved the install.lock file one level up and then paste it down after install has been completed.


Glad you found it.

I generally rename the file from “install.lock” to “minstall.lock” so as to only one letter or remove one letter.


Hi. I have same error. Delete install.lock from everywhere but still error. Can you help me?

This is one of those self help situations. If you are getting the “install.lock” error, your server has the file somewhere in the Dolibarr directory. You need to search the whole directory for install.lock

In my case, I have Dolibarr installed on a local Ubuntu server. I would use FileZilla to search the whole Dolibarr directory recursively until finding the file.

Good Luck,