Maximum length for lists

Hello everyone, currently when I enter any list, whether it’s projects, third parties, or tickets for example, it generates a list with 50 rows. I can manually increase or decrease it in the top menu. However, I would like to change this default value from 50 to 250. Where can I make this change? I have already tried to do this in ‘Settings > Appearance > Default maximum length for lists’ and it had no effect.

go to Home > Settings > Other and add the following parameter to the boxes here “MAIN_MAXLIST_OVERLOAD” 20 - 50 or your choice.

Thanks, Umigun, for the information. However, after making modifications in my instance, it continues to display a list with a value of 50.

The system constant to change is this: MAIN_SIZE_LISTE_LIMIT

But you can set it manually on:

  • Setup > Display > Lang.& presentation > Default max length for lists

So there must be something wrong with my instance, both with the MAIN_SIZE_LISTE_LIMIT command and the manual way you explained to change the size of my list. See the prints below.

Is it possible that some kind of cache is interfering? Try to test the list length on other web browser (to discard browser cache interference), or try with a new user (to discard “user cache” of Dolibarr), or try also to PURGE temporal files/settings on Dolibarr (on Admin Tools):


Caos30, you were right, the cache was interfering. But this has brought to my attention another issue: is it also possible to set a custom value per user? When I tested with another user, it worked, but it was still problematic on my account. Then I went to the user settings and discovered this function. Thank you very much for the help.

1 Like