Setup not allowed by conf.php permissions

I am new to Dolibarr but not to web servers nor Linux so I know my permissions are right but I still get this error on a fresh Centos installation.

My config.php is chmodded 666 and the ownership is correct (apache). In the screencaps attached the pre-req check has a green tick but still says “Configuration file htdocs/conf/conf.php is not writable. Check permissions…”

What else could it be?


1 Like


re-upload conf.php or…
change permissions and then change back to what they should be or…
delete cache

Hope it helps

1 Like

I tried all that and more. In the end I ditched Centos and used Ubuntu as I am just testing the software for a much bigger future project.

Working fine now except I have come across other issues which I am about to post about :wink:

Thanks anyway.

Hm, ironically, I have a working version of dolibarr on ubuntu and went with centos on another machine.

And I have this issue.

On Centos 7 Selinux is disabled by default… So nothing to touch with that.

For the writable conf.php file, did you try this? ->

From Dolibarr root directory:

chown -R apache.apache htdocs/conf/conf.php

chmod -R 755 htdocs/conf/conf.php

Also don’t forget to set conf.php to 644 or 444 after successful install (to stop security error warnings once logged in).

Hope it helps.

1 Like