Setup of module TakePos looks to be uncomplete. Go on Home - Setup - Modules to complete

Please Guide me how to resolve this issue


In your first tab (main Dolibarr, not POS)… go to Home > Setup > Modules

What kind of solution is this? When you get to Modules what do you do next.?

Got to that section and complete the setup… its a simple solution based on the simple screenshot - without explanation - by the user.

Hi all,

i have the same problem but i have no idea, what option makes the problem???

The problem appears when you select a product.

Is there a required option under modules - product or in the products?

Was there a solid solution to this error? Looks like no matter how much configuration you do, TakePOS still says it’s “uncomplete”
I filled in all the required settings but this error won’t go away.

Can you provide a screenshot of the setup page for terminal 1.

Terminal is not configure. make screen shot of the settings in terminal 1

Thanks for the response. I hope this can be solved.


Should not be empty

1 Like

Thanks for the pointer. I had not setup a default customer. I presumed that it should work without one as a shop. More helpful info on this link : how to Default generic third party to use for sell

Hi, The “Default generic third party to use for sales” need to have a customer created. Create a customer called “Walkin Customer” at Third Parties.
Also create a Cash account in “Bank Accounts” and allocate it to “Default account to use to receive cash payments”
enter 13 in the Key code for “Enter” defined in barcode reader (Example: 13)
I hope this will help

I had the same problem. Below are the quick steps to resolve. May not be int he proper or detailed order but it works.

  1. Add bank, bank account (cash and credit/current)
  2. Add product category. Add product and attach it to the category.
  3. Add customer category. Add a customer and attach it to the category.
  4. TakePOS plugin > Parameters tab - make sure everything required is filled.
  5. TakePOS plugin > Terminal1 tab - Make sure everything is filled there eg attach bank account for cash and credit, ASCII field and type 13 there. If you leave any of the fields in this section then when you make a sale as cash it will show error again. So make sure all fields are filled here.

Hope it helps anyone.
And a request, please dont be mean and give half answers to new people or people who dont know.

1 Like

I had the same problem, and the last thing that i had to set is:

  1. in module BANKS: create a type of account CASH and and an account of type BANK ACCOUNT
  2. in module TakePOS settings, tab Terminal 1: choose one of them ONLY in the first selectors of kind “default account for cash payments”, and “…for check payments”, and for “…credit card payments”.

Note for developers: it would be very appreciated that the error message mentioned what was exactly missing in the terminal configuration. I’ve been developing Dolibarr modules since Dolibarr 5 and i passed almost an hour desperating trying whatever i thought to solve it and finally only arriving to this forum post it suggested me to try this solution above. So please, this is NOT ACCEPTABLE error messaging to the users trying to configure the module :sweat_smile:

1 Like

hello @caos, if you are a so much experienced developer, it should be easy for you to contribute to the dolibarr core with a fix for a better message :wink:

Thank you for sharing, this worked for me. Step no. 3 to be specific. I had created a customer on the “Third-Party” module but I had not created a “Category” for the customer and added the customer to the category. After I did, it cleared this error and worked.