Update Dolibarr from 3.9.3 to 17 version

Hi, i’m in trouble with update from 3.9.3 version to 17 version, because I end up with project data yes but without some fields that are very important to me such as “password”, “email”, etc…
How can I update with this data too?

Thanks. :slight_smile:

Hi @Mickyhood,

can you explain a bit more about how you did the upgrade? Did you upgraded to version 4.0.6, then to 5.0.7 and so on or did you directly added the files for version 17? I read somewhere in the forum, that the first described approach should be preferred as there might be some bugs if you directly want to migration from an very old version to the latest version of dolibarr. Can you try this?

Appart from that,

  1. Are you using external modules?
  2. Are there any errors in the logs (Dolibarr or Apache Error Logs)?
  3. Are extrafields on the projects the only missing data?

Best regards,

Hi @ sp_digitalcentric.de, and thanks for the answer.

I have updated step by step each version of 4.0, but i’ll do another test today, let’s see what happens.

I don’t have weird modules installed just the projects and the “fck editor”.

Yes yes only the extra fields are not shown, which I absolutely need to be shown.

Hi, @sp_digitalcentric.de

I had to redo the procedure to be sure. Basically I downloaded version 17 of dolibarr and replaced all the files (FTP) within my installation of version 3.9.3. I copied and overwrote the files from everything except the “conf” directory into “htdocs”. At that point the program saw the update and I had to go through all the versions up to the latest, namely 17, but many data such as “email”, “password” and other info are no longer there.

How can I do to solve the problem?

Hi @Mickyhood,

I hope you did a backup of your data before you startet the migration. You should always backup your database and the documents folder.
As mentioned before, I think you should do a step by step upgrade. So first add the files of the latest next version, in your case 4.0.6. and migrate to this and then to the next version.

Apart from that it would be good if you answer my questions to get a better understanding what happens.


Hi @sp_digitalcentric.de,
yes yes I’m working in a separate area dedicated to these tests. The site in production that I use every day I’m not really touching.

To answer your questions, I’ll do this, I’ll give you 3 points so you understand better:

  1. No, I’m only using the fckeditor module and projects;

  2. as log errors I have the following, but it will be due to the fact that to do the update I had to recreate the htdocs directory since whoever had made the site at the time had moved all the files inside htdocs to the main directory:
    AH01276: Cannot serve directory /var/www/vhosts/studioquadra.it/dev.studioquadra.it/: No matching DirectoryIndex (index.html,index.cgi,index.pl,index.php,index.xhtml,index.htm ,index.shtml) found, and server-generated directory index forbidden by Options directive

  3. Yes, there are fields like “email”, “password”, “FTP account”, “FTP password” and other similar things.

Now I’ll do as you told me, I’ll pass version by version manually via FTP, let’s see what happens.

In the meantime, thanks for the replies.

Hi @Mickyhood,

thanks for the clarification. If really only the project extrafields mentioned in point 3 are missing, then another approach could be to copy only these from the old database before migration to the new one after migration. But if the approach you are trying now works, this would be the cleaner way to solve it. I can recommend to check if the fields missing after each version migration step. This information could help solving the issue.


Hi @sp_digitalcentric.de,
but you say is it possible that by changing the version of dolibarr, the software will delete the tables of that data? is this possible?

PS: i’m arrived to the version 5.0.6 without problems but i noticed that the position of the dolibarr tables have changed a bit, but the data is there.

I think it will not delete them on purpose, it could be a bug. As mentioned I read somewhere in the forum that a direct migration to V17 is not always working if the initial dolibarr Version is very low and I would consider Version 3 as very low in this case. There where some fixes for the migration but they are not contained in the latest migration scripts. Thats at least what I read. Therefore it is more save to do the step by step approach, specially if something didn’t worked.


@sp_digitalcentric.de hi,

after almost 3 hours where i worked as follows i managed to solve, now i’m at version 17.03 with all data imported.

  1. As you told me, I took version 4.0.6 and uploaded the files via FTP
  2. I copied everything into the root directory but without the htdocs directory;
    3 I copied the htdocs directory but without the internal “conf” directory so as not to lose the db data;
  3. I went to the site and did the update.

Now from version 16.0.5 I also raised the php version to 8.1.

Here is the list of versions used:
16.0.5 with php 8.1
17.0.3 with php 8.1

How do you think the procedure is correct?

Hi @Mickyhood,

thats exactly the approach I mentioned. From procedure perspective this seems fine for me. Important is that all your data is available and also the rest works correctly. So I recommend to do now a proper test of your main use cases to check everything is working.


Hi @sp_digitalcentric.de, yes, it seems to me that everything is there but I will keep the development area active so as to see if I can do some tests perhaps at the same time as the production area.
Thank you so much, you’ve been very helpful :slight_smile:

Hi @sp_digitalcentric.de, I’m resurrecting this discussion after realizing something: is it normal that not all the fields in Dolibarr 17 can be filled in with “Word style” text formatting?


Yes, only some fields have the HTML possibility.

@ksar but it’s normal? Are fields different from the 3.9 version, is correct?

You need to be more precise in your question : What Field Exatly ?

for exaple, the field “Note e Timeline” in the 3.9 version is in HTML but not in 17 version. Is this correct?


I don’t know exactly where “Note e Timeline” is unfortunately.
You can check on Dolibarr ERP/CRM demo to see if you have the same behavior.

And, just to check, WYSIWYG editor is activated ?

No, i have activated now but the situation does not change.

I was referring to the Notes and Timeline table anyway.

Can anyone help me? I’m in trouble with the editor HTML that which is not present on the fields.