Upgrade from V14.0.5 to 15.0.0

i have try to upgrade my installation i see that is not saying that is upgrade database from V14 to V14? after upgrade i get this error when i try search for product

more info i have a tryout server where it worked but then i upgrade SQL database to V14.0.5 from main server then now i have same problem on my tryout server

On my server after copying version 15 files I can only see upgrade to version 14.0.5, migration to 15.0.0 is not available

yes i think that was same issue here it says start upgrade from V14 → V14 and not V15

I manually changed parameter in url to force version 15 but it doesn’t change the result, still on version 14.0.5 I have put EXPERIMENTAL to 0 too but nothing

I don’t understand why, but I finally got version 15 installed. I am sure about these 2 steps:

  • reloaded all the files to dolibarr folder asking to FileZilla to replace all (before I selected replace newer)
  • started installation process in browser with Private Mode and cache purged

It worked.


i have try to install it again with a new download but it still gives error see attach picture

and this is install on a local machine

and also this error when i try to make an offer

and still tell me that i am in a develop version

i still have this problem with my try out server see picture

Failed to insert event : Unknown column ‘num_vote’ in ‘field list’

is there any that have seen this before i can see some french have same issue back in update from V13 to V14

i have now upgrade to V15.0.1 and i get this in my log see under here but still same error as before

Any help to this issue it look like missing field in database but it must be relatet to v14.0.4 or 5 See log in attach pdf DolibarrLog.pdf (70.5 KB)

System is
Ubuntu 20.04.4
Browser Firefox V98,0
PHP 7.4.3
Mysql 5.5.5

I found that it miss this 3 table/parameter in Data tabel llx_actioncomm ? see picture but is it the right set of data or shut it be integer or something

Answer is there : dolibarr/llx_actioncomm.sql at develop · Dolibarr/dolibarr · GitHub

  num_vote          integer DEFAULT NULL,          -- use for Event Organization module
  event_paid        smallint NOT NULL DEFAULT 0,    -- use for Event Organization module
  status            smallint NOT NULL DEFAULT 0,    -- use for Event Organization module for now, but could be use after for event global status

yes then it is working on my try out station.

but for other with comparable problem it was related to ownership and group of file in /usr/share/dolibarr