Upgrading from 17.0.2 to 18.0.2

Hello to everyone!
I’m experiencing problems trying to update an 17.0.2 installation on my hosted website to the version 18.0.2.

Dolibarr is installed on a folder named “dolibarr”, absolute server path “/web/htdocs/www.mysite/home/dolibarr/”.

I tried to extract dolibarr-18.0.2.zip content into

  1. “/web/htdocs/www.mysite/home/” folder
  2. “/web/htdocs/www.mysite/home/dolibarr/” folder
    but without success.

In both cases opening my browser to the install path of dolibarr, it shows a page that wants to update to 17.0.2, not the 18 version!

The only difference between 1 and 2 cases is that with #2 dolibarr was usable; with #1 any page of dolibarr openend the index of the install folder, but anyway it wanted to install 17.0.2. already installed.
Colud someone please help me?

Thanks in advance


Dolibarr-18.0.2.zip contain a htdocs folder.
What do you have in “/web/htdocs/www.mysite/home/dolibarr/” folder ?
The idea is to overwrite files.

Hi there,

I try to upgrade the version 17.0.2 to the 18.0.2 too. After overwrite all the files, the install check still show the 17.0.2 version to install instead of the 18.0.2. I think this is a bug of the installation process.


Either you have a cache system on your hosting, or you do not overwrite the good files.

No cache, i’ve done this for a long time, that’s not a copy problem, all the files are with the same date that are in the zip file

Last solution is the zip file, is the 17.0.2 not the 18.0.2

all the files are dated on the 6th October, so i don’t think this is the 17.0.2

Hello, what happened with this topic. I’m having the same problem, I copied and overwritten all the DoliBarr v17 files with V18 but when I run the installation script it makes nonsense and tells me that everything is ok. But upon entering it is still v17 or at least that is what it says.

Thanks to everyone.
Unfortunately I didn’t solve this issue.

As a remark for @ksar : in “/web/htdocs/www.mysite/home/dolibarr/” folder I have a lot of folders and also htdocs folder. Inside it, there are another list of folders and some files.

The problem here seems to be that you need to replace the files in same location. Do not upload the entire contents of the zip-file, but only the contents of the htdocs -folder to /web/htdocs/www.mysite/home/dolibarr/.

I think you have created another Dolibarr installation inside your current Dolibarr installation. That would explain why the old version is coming up.

I followed your instructions and I replaced only content of htdocs folder: calling the Install link I have again only the option to ugrade to 17.0.2.

The following row doesn’t make sense (at least for me):
Ultimo aggiornamento di versione: 17.0.2 - Versione programma: 17.0.2


Then you need to replace files in your web/htdocs/www.mysite/home/dolibarr folder not in htdocs