Installing Dolibarr 18.0.3 failed

Hello everybody!
I use Dolibarr 17.0.2 on Windows 10 and Chrome.
Today I tried to install verison 18.0.3 an I got the attached message. Can anybody help please. I must work this weekend. I have a backup copy.
Should I continue and ignore the errors or just reinstall version 17.0.2?
Thank you for helping

What if you upgraded
17.0.2 → 17.0.3
17.0.3 → 18.0.0
18.0.0 → 18.0.1
18.0.1 → 18.0.2
18.0.2 → 18.0.3

Thanks for your answer.
Sadly I tried to upgrade directly from 17.0.2 to 18.0.3.
Is there a possibility do downgrade again to 17.0.2?

if the upgrade failed as your picture indicates, wouldn’t you still be running the old version?

And if not, what about your backup?

This Looks like an issue on your llx_product_stock table fk_product column being the reference of llx_product (row_id column).

i suggest you check your llx_product_stock table id you have duplicate fk_product.
→ select fk_product, count(1) from llx_product_stock having count(1) >1;

@Maslino I think you quoted the wrong person

yes sure, @jonbendtsen i intended to reply to the original query by @electrosecserv

Hello everyone!
Thank you for your answers.
Finally I had to uninstall Dolibarr, install a fresh copy and restore the backup.
Everything is OK now

1 Like

Hello again!
Today I tried to upgrade as you suggested, 17.0.2 to 17.0.3 everything OK.
But when I tried to upgrade from 17.0.3 to 18.0.0 the same happened

which PHP versions do you use with the different dolibarr versions?